OK
In progress indicator

no flowers

In progress indicator
Full size image

Question from D.Johnson

Close

House rules are loading...

In progress indicator

We are processing your monitoring request...

In progress indicator

In progress indicator

Comment on a listing

Comment on a listing

Comment on a listing

Cancel and close this form

i planted bulbs this spring and they have grown well but no flowers yet and it is now August. Any siggestions why this is as they get a least 6 hrs of sun a day and are in well fertilised and free drainy soil

  • Views: 987
  • Replies: 4
  • Posted: Wed. 3rd August 2011 09:47

Re: no flowers

Reply from Matt D-W

Hi.
Mine have also done the same this year. After reading up about them it states they flower August, September, October.
Did yours end up flowering?

  • Posted: Sun. 12th August 2012 20:46

Re: Re: no flowers

Reply from John Streets

Here in the S.W. of France, and in spite of very hot summers, mine often only show the first bloom in September, but then they continue flowering until the end of November. I dead-head and lift the bulbs, replanting in pots in mid-March.

  • Posted: Sat. 17th September 2016 13:44

Re: no flowers

Reply from Fannie Leigh

I think these are real stunners. I put them in a pot in March, and like you expect flowers - then at the end of August, they came into full bloom, and still are - such a joy at this time of year! Mine were saved from last year; I tend to lift/dry/store and pot up the offsets in the greenhouse for more stock. Hope yours are in flower now.

  • Posted: Sat. 6th October 2012 17:31

Re: Re: no flowers

Reply from Jenny Blain

Acidanthera are beautiful. I put in some corms in May - they flower very late, and a few of mine haven't flowered, possibly because of the cold weather in May. However most have done so, starting at the end of August and some still going now, in early November. I need to get them up soon, but am waiting for the foliage to turn brown.

  • Posted: Mon. 4th November 2013 16:31